Heute will ich Euch ein weiteres DIY-Projekt vorstellen. Ich zeige Euch, wie Ihr einen 8-fach Temperatursensor selber aufbauen könnt um damit z.B. die Vor- und Rücklauftemperatur Eurer Fußbodenheizung zu messen. Denkbar sind auch Anwendungen für den Pool, die Wärmepumpe usw.. Mit dem Bausatz könnt Ihr bis zu 8 unterschiedliche Temperaturen erfassen und diese direkt in der Homematic CCU auswerten und verarbeiten. Vor ein paar Wochen hatte ich Euch dieses Projekt bereits vorgestellt und dafür die universal-Platine von Alexander verwendet (zum Artikel).

Da ich selbst bei meiner Fußbodenheizung die Vorlauf und auch Rücklauf-Temperatur messen will, habe ich in KiCad eine eigene Platine entworfen, damit ich die 8 Sensoren schnell per Schraubklemmen anschließen kann. Außerdem wollte ich ein System, das unabhängig von Batterien funktioniert. Daher habe ich die Platine so ausgelegt, dass diese mit 24V arbeitet. In meinen Verteilerkästen für die Fußbodenheizung liegen bereits 230V, da ich hier bereits den FAL230-C10 verbaut habe. Für den Betrieb reicht ein kleines 230V / 24V Netzteil von Meanwell, welches man für wenige Euro bekommt. In dem älteren Artikel lief die Messung per Batterie, doch die 230V Lösung gefällt mir wesentlich besser…

Was benötigt Ihr alles für diesen Bausatz?

  • 1x Grundplatine könnt Ihr über unsere Shop beziehen
  • 1..8x DS18B20 Fühler
  • 1x Arduino Pro Mini 3,3V mit 8 MHz
  • 1x Funkmodul 868MHz (CC1101)
  • 1x Antennendraht 8,6cm (1mm Abisoliert)
  • 1x SMA Sockel für externe Antenne (optional)
  • 1x Taster 6x6x5mm
  • 1x Elko 10uF 1,5mm
  • 1x Universalgehäuse
  • 4x Blechschraube M2
  • 1x 470 Ohm Widerstand für die LED
  • 1x 4,7k Ohm Widerstand für die Fühler
  • 1x Netzteil 24V

Dateien zur Platine (Gerber) findet Ihr hier.

Wo am besten kaufen?

Ich habe alle Teile mit µ-Elektronik bei Aliexpress bestellt, die Bauteile wie Widerstände, Taster, das Gehäuse und die anderen passiven Bauteile bei Conrad. Der komplette Bausatz wird auch bei uns im Shop zu kaufen sein. Dort ist dann bereits alles vorhanden, was Ihr für den Aufbau benötigt.

So sieht der fertig aufgebaute Bausatz aus. Ich habe in diesem Beispiel nur 2 Sensoren angeschlossen. Ihr seid bei der Anzahl komplett variable, sodass 1-8 Sensoren verwendet werden können.

AmazonAliexpressConrad
ELV
Grundplatine (Webshop)
6-25V FestspannungsreglerLink
SchraubsockelLink
DS218B20 SensorLink
Arduino Pro MiniLinkLink
FunkmodulLinkLink
Antennendraht
LED 3mmLinkLink
R1 = 470 OhmLinkLink
R3 = 4,7K OhmLinkLink
Taster 6x6x5mmLinkLink
Elko 10uFLinkLink
UniversalgehäuseLink
Blechschraube M2Link
Sicherung
FTDI AdapterLinkLink
24V NetzteilLink

Zusammenbau des Sensors

Zuerst wird der Arduino eingelötet, wie auf den Fotos zu sehen ist. Vergesst dabei bitte nicht die Pin A4 und A5, diese befinden sich im inneren.

Danach wird das CC1101 Funkmodul verlötet. Hier könnt Ihr entscheiden, ob dieses auf die 2mm Pins gesetzt werden soll (wie im Foto). Ihr könnt das Modul aber auch direkt auf die Platine löten, dann entfallen die 2mm Pins.

Nun folgt der Festspannungsregler, der dafür sorgt, dass die 6-24V Eingangsspannung zu 5V gewandelt wird. Der Festspannungsregler arbeitet von 6-25V, so könnt Ihr auch ein Netzteil mit 10V oder 12V anschließen!

Achtet bitte auf die richtige Ausrichtung wie im Foto. Das Modul wird auf 2,54mm Pins gesetzt. Es folgen dann die LED, der Taster und die Sicherung. Ihr könnt auch direkt den kleinen Elko mit einlöten. Der Balken auf den Elko muss zur ausgefüllten Fläche auf der Platine zeigen.

Bei den Widerstanden müsst Ihr für R1 den 470 Ohm verwenden und für R2 den 4,7k Ohm.

Nachdem nun alle Bauteile verlötet worden sind, folgen die Schraubklemmen. Diese werden so platziert, wie im Foto zu sehen. Die Schraubklemmen der Sensoren 1-5 stehen sich gegenüber.

Nun können wir die Sensoren anklemmen. Je nachdem, welche Sensoren Ihr vorliegen habt, kann die Farbe der Adern variieren. GND ist in diesem Fall schwarz,

Nun können wir die fertige Platine in das Gehäuse setzen und mit den Schrauben fixieren. Es werden nur 4 Stück benötigt. Die Kabel für die Spannungsversorgung und die Messleitungen habe ich durch die Öffnung am Gehäuseboden geführt.

Hier seht Ihr das fertig aufgebaute Gehäuse mit einen 24V Netzteil. Das Netzteil auf dem Foto ist etwas groß, es kann natürlich auch ein kleineres Netzteil (24V) verwendet werden.

Frequenz des CC1101 anpassen

Falls Ihr Probleme beim Anlernen des Sensors habt, solltet Ihr Euch bitte zuerst diesen ausführlichen Artikel zum Thema Frequenzanpassung des CC1101 durchlesen.

DIY-Sensor programmieren mit dem passenden Sketch

Zuerst müssen wir die Arduion IDE Software herunterladen. Diese gibt es für Windows, Mac und Linux.

Nachdem der Download beendet ist, müsst die die Installationsroutine durchlaufen und das Programm starten.

AskSinPP herunterladen

Um zu starten benötigen wir zuerst AskSinPP. Über die Schaltfläche „Clone or download“ rufen wir ein weiteres Fenster auf. Hier wählen wir nun Download ZIP aus.

Nachdem die Datei heruntergeladen ist entpacken wir die Datei in einem temporären Ordner.

Nun müssen wir aus den soeben entpackten Dateien ein neues Archiv machen, jedoch ohne das zusätzliches Unterverzeichnis AskSinPP. Im neuen ZIP-Archiv sind dann direkt die Ordner bootloader, examples usw… zu finden. Das neue Archiv kann den gleichen Namen wie das alte Archiv tragen.

Wir brauchen diese Datei gleich, um die ZIP-Datei als zusätzliche Library in Arduino IDE einzubinden.

Einbinden der AskSinPP Bibliothek

Die soeben angelegte ZIP-Datei spielen wir jetzt in das Arduino IDE ein. Dazu klicken wir im Hauptfenster auf „Sketch“ und dann auf „Bibliothek einbinden“ dort wählen wir dann „.ZIP-Bibliothek einbinden…“ an.

In dem neuen Fenster wählen wir nun unsere soeben erzeugte ZIP-Datei aus.

Damit haben wir die wichtigste Bibliothek für die Funktion unseres neuen Sensors eingebunden!

Sketch herunterladen

Nun laden wir die fertigen Sketche für den Sensor herunter. Diese bekommen wir bei GitHub von Jerome.

Auch hier wählen wir wieder „Clone or download“ an und laden die ZIP-Datei herunter.

Ich habe das Archiv direkt in den Ordner der Arduino-Installation geschoben. Diesen findet Ihr unter „Dokumente“ –> „Arduino“. Hier habe ich alle Beispiele abgelegt, die in der ZIP-Datei von Jerome vorhanden sind.

Zusätzliche Bibliotheken installieren

Zuerst müssen aber noch weitere Bibliotheken geladen werden, damit das Projekt laufen kann.

Wir brauchen folgende Bibliotheken, die noch installiert werden müssen:

Fangen wir mit der ersten Bibliothek an. Diese installieren wir über das Haupfenster mit einem Klick auf „Sketch“ –> „Bibliothek einbinden“ –> „Bibliothek verwalten…“

Es öffnet sich ein neues Fenster. Dort können wir dann nach der benötigten Datei suchen.

Wir geben als im Eingabefeld „EnableInterrupt“ ein und wählen die aktuelle Version aus und danach auf „Installieren“.

Damit haben wir nun die erste Bibliothek eingebunden.

Die nächste Library, die wir benötigen können wir hier von GitHub herunterladen. Auch diese Bibliothek binden wir wieder über die Schaltfläche „Sketch“ –> „Bibliothek einbinden…“ und dann auf „.ZIP-Bibliothek hinzufügen…“.

Damit haben wir nun alle nötigen Dateien zusammen und können jetzt das Board konfigurieren!

Board Konfigurieren

Nun müssen wir dem Programm noch mitteilen, welches Board wir programmieren wollen. Dazu klicken wir auf „Werkzeuge“ und tragen dort die Information ein, die Ihr im Bild sehen könnt.

Sketch laden

Nun müssen wir das fertige Sketch laden, um den Sensor zum Leben zu erwecken. Das Sketch ist wie ein Programm, welches auf den Prozessor vom Arduino geschrieben wird.

Hier sind die Einstellungen nochmal einzeln aufgeführt. Um an den COM-Port des FTDI-Adapters zu erhalten, muss der Adapter an den Computer angeschlossen werden. Ihr könnt dann im Gerätemanager den passenden Port sehen. In meinem Fall ist das COM7.

  • Board: Arduino Pro or Pro Mini
  • Prozessor: ATMega328P 3.3V 8MHz
  • Port: Der COM Port vom FTDI Adapter

Arduino flashen

Jetzt haben wir soweit alles vorbereitet, dass der Arduino programmiert werden kann. Dazu müssen wir den Programmer auf 3,3V umstellen. Auf der Platine ist dafür ein Jumper angebracht. Dieser kann entweder in der Stellung 3,3V oder 5V gesteckt werden. Wir müssen diesen für unseren Arduino auf 3,3V stellen.

Nun klicken wir im Fenster auf „Sketch“ –> „Überprüfen / Kompilieren“.

Wenn Ihr bis hier alles richtig gemacht habt, dann können wir das Programm nun auf die CPU schreiben.

Dazu klicken wir auf „Sketch“ –> „Hochladen“

Auch dieser Vorgang dauert etwas und Ihr könnt beobachten, wie die beiden roten LEDs am Programmer während des Vorgangs blinken.

Damit haben wir erfolgreich die Software auf das Gerät gespielt!

88 Kommentare
  1. Avatar
    Dieter sagte:

    Erfahrungsbericht Funkstrecke
    Hallo allerseits,
    jetzt muß/darf ich mich nach längerer Zeit nochmal melden. Ich habe den Sensor für Heizungslogging im Heizungskeller montiert und hatte anfangs Bedenken wegen der Funkstabilität (CCU im EG, bewehrte Betondecke dazwischen, stählerne Feuerschutztür zum Heizungskeller). Ich kann alle Mitleser beruhigen. Obwohl ich gleich mal auf externe Antenne (auch Technikkram) umgebaut hatte um die Möglichkeit zu haben diese außerhalb des Heizungsraums anzubringen, betreibe ich den Bausatz mit direkt am Gehäuse angebrachter Stummelantenne im Heizungskeller und was soll ich sagen: Völlig problemlos.
    Noch was am Rande: Alle Sensoren sind ja parallel geschaltet, die Beschriftung (Sensor 1…8) ist also eigentlich völlig egal. Die Reihenfolge wie die Sensoren in der WebUI erscheinen hängt anscheindend von der Seriennummer aufsteigend sortiert (?) ab (kann das jemand von Technikkram grad mal bestätigen?). Deshalb wäre es vielleicht sinnvoll die Nummern beim Aufspielen des Sketches gleich auszulesen und sie dann der Reihenfolge (Seriennummer) nach auf die Plätze (Sensor 1..8) anzuschliessen. Schaut dann einfach schöner aus in der WebUI :-)

    Antworten
  2. Avatar
    Robert sagte:

    Das schaut ja alles gut aus oder ????? Und die gacke will einfach nicht an die Raspimatic anlernen, Fu…….
    Kann wer helfen bitte

    AskSin++ V4.1.5 (May 20 2020 19:33:02)
    CC init1
    CC Version: 14
    – ready
    Start searching …
    Freq 0x21656A 868.300 MHz: BBA765. 1 / -47dBm
    Search for upper bound
    Freq 0x21657A 868.306 MHz: 70F97C. 1 / -51dBm
    Freq 0x21658A 868.313 MHz: BBA765. 1 / -44dBm
    Freq 0x21659A 868.319 MHz: 7B774D. 1 / -47dBm
    Freq 0x2165AA 868.325 MHz: BBA765. 1 / -46dBm
    Freq 0x2165BA 868.332 MHz: AD899B. 1 / -84dBm
    Freq 0x2165CA 868.338 MHz: 9F159F. 1 / -65dBm
    Freq 0x2165DA 868.344 MHz: 0
    Search for lower bound
    Freq 0x21655A 868.294 MHz: 0

    Done: 0x21656A – 0x2165CA
    Calculated Freq: 0x21659A 868.319 MHz
    Store into config area: 659A…stored!
    AskSin++ V4.1.5 (May 20 2020 19:37:34)
    ID: F30101 Serial: UNITEMP001
    Address Space: 32 – 358
    CC init1
    CC Version: 14
    – ready
    iVcc: 3403
    Config Freq: 0x21659A
    Found 1 DS18B20 Sensors
    Config Changed List0
    LOW BAT Limit: 22
    Sendeintervall: 180
    OFFSET: 0
    OFFSET: 0
    OFFSET: 0
    OFFSET: 0
    OFFSET: 0
    OFFSET: 0
    OFFSET: 0
    OFFSET: 0
    Temperaturen: | 251 | 0 | 0 | 0 | 0 | 0 | 0 | 0 |
    <- 16 01 86 53 F30101 000000 00 41 00 FB 42 00 00 43 00 00 44 00 00 – 833
    <- 16 02 84 53 F30101 000000 00 45 00 00 46 00 00 47 00 00 48 00 00 – 1126
    debounce
    pressed
    released
    <- 1A 03 84 00 F30101 000000 10 F3 01 55 4E 49 54 45 4D 50 30 30 31 70 08 01 01 – 1187

    Temperaturen: | 251 | 0 | 0 | 0 | 0 | 0 | 0 | 0 |
    <- 16 04 84 53 F30101 000000 00 41 00 FB 42 00 00 43 00 00 44 00 00 – 21946
    <- 16 05 84 53 F30101 000000 00 45 00 00 46 00 00 47 00 00 48 00 00 – 22245
    Temperaturen: | 251 | 0 | 0 | 0 | 0 | 0 | 0 | 0 |
    <- 16 06 84 53 F30101 000000 00 41 00 FB 42 00 00 43 00 00 44 00 00 – 23015
    <- 16 07 84 53 F30101 000000 00 45 00 00 46 00 00 47 00 00 48 00 00 – 23308
    debounce
    pressed
    released
    <- 1A 08 84 00 F30101 000000 10 F3 01 55 4E 49 54 45 4D 50 30 30 31 70 08 01 01 – 23369

    Antworten
  3. Avatar
    Volker sagte:

    Hallo,
    mein Temperatursensor funktioniert seit Monaten tadellos.
    NUR, sobald ich meine Zentrale neu starte wird der Sensor nicht mehr erkannt.
    Letzt endlich muss ich auf der Zentrale mein Betriebssystem komplett neu auf die SD-Karte spielen und anschließend das Backup einspielen. Ist kein Hexenwerk aber sehr nervig.
    Hast du mir einen Tip zur Fehlerbehebung.
    Habe ein Raspberry Pi3, RaspberryMatic 3.51.6.20200229 und JB HB Devices V 1.25.

    Antworten
    • Avatar
      Roland sagte:

      Meine Sensoren laufen nun auch seit Monaten. Leider hatte ich vergangene Woche eine Platine die plötzlich eine „Kommunikationsstörung“ gemeldet hat. Strom aus ein und drücken auf den Knopf und sie geht wieder.
      Überraschende Kommunikationsstörungen hatte ich allerdings gelegentlich auch mit Rolladenaktoren.
      Als Reaktion (Lösung) habe ich eine ext. Antenne an die CCU gebaut.

      Antworten
  4. Avatar
    Sven sagte:

    Hallo,

    ich schaffe es nicht den Sensor zum Laufen zu bringen.
    Wenn ich bei der Arduion IDE Software das Board richtig einstelle und dann die Boardinformationen hole, bekomme ich nur folgende Informationen.

    BN: Unbekanntes Board
    VID: 0403
    PID: 6001
    SN: Laden Sie irgendeinen Sketch hoch, um sie abzurufen

    Ich kann zwar den Skin ohne Fehler hochladen, danach ist trotzdem im Serial Monitor nichts zu sehen.

    Auch beim FreqTest bekomme ich im Serial Monitor nur folgende Informationen.

    18:55:40.799 -> ⸮pjfd&⸮⸮⸮⸮<8⸮p⸮3⸮

    Was läuft da falsch?

    Hoffe auf Hilfe, sonst ist der Sensor für die Tonne.

    Antworten
  5. Avatar
    Sven A. sagte:

    Hallo,
    habe die Platine soweit ans laufen gebracht und angelernt.
    Leider wird mir keine Temperatur angezeigt. Auch im Seriellen Monitor (Arduino IDE) stehen alle 8 Kanäle auf Null.
    Anscheinend werden (wird) der/die Sensoren nicht erkannt.
    Gibt es einen Lösungsansatz?

    Antworten
    • Avatar
      Heiko sagte:

      Hallo Sven !
      Hast Du für Dein Problem eine Lösung gefunden ?
      Ich hab das Ding gerade montiert und habe gleiche Herausforderung. Habe das Gefühl, dass ich den Code zu MultiChannelDevices.h nicht korrekt eingebunden habe. Bin aber unerfahren rund um Arduino.

      Hast Du einen Tip ? sonst steige ich mal in die Lösungssuche ein
      Grüße
      Heiko

      Antworten
      • Avatar
        Heiko sagte:

        So, Nachgedacht und rumprobiert. Bei mir hat eigentlich alles funktioniert, dann aber kein Sensor erkannt und demnach nur „0“ als Messwert.
        Ursache war ein defekter Sensor. Dieser hatte zwischen Data und + Durchgang, so dass alle parallel geschalteten Sensoren damit mit totgelegt wurden.
        Fehlersuche daher bei mir zunächst: Alle bis auf einen Sensor entfernen, dann schauen was passiert. Sensor für Sensor dazunehmen, jedesmal Reset und im seriellen Monitor zuschauen, ob es immer ein Sensor mehr wird, oder plötzlich wieder keiner mehr gefunden wird.

        Antworten
      • Avatar
        Sven A. sagte:

        Nein, ich habe jetzt lange nichts mehr gemacht.
        Ich würde es nochmal mit einem anderen Snesor testen wollen ( hab ja bisher nur einen getestet)
        Evtl. liegt es bei mir auch daran, das ich die Platine bisher nur mit einer 9V Batterie gespeißt habe.

        Antworten
  6. Avatar
    Raik sagte:

    Hallo und guten Tag.
    Bei mir ist der Aufbau und die CCU-Einbindung erfolgreich verlaufen. Leider friert die Temperaturerfassung meines Heizkessels bei ca. 75°C ein. Ist ein Lösungansatz vorhanden?

    Antworten
  7. Avatar
    Uwe sagte:

    Hallo Sebastian und @all
    Soweit habe ich die Platine in Bertrieb genommen und konnte sie auch auf meiner CCU3 anmelden. Problem jetzt ist, dass ich nur einen Zweifachtaster als Gerät in der CCU3 angezeigt bekomme. Gruß Uwe

    Antworten
    • Avatar
      Torsten sagte:

      Hallo Uwe,
      ich glaube ich habe das selbe probelm…
      wie bekomme ich die Datei/Skript in den Ardu. rein?

      2. Wird die Drahtantenne nur in der Mitte der drei Lötösen auf dem Transceiver verlötet oder können/müssen alle Lötpunkte genutzt werden?

      3. Wie prüfe ich nach, ob alle „Treiber“ auf den Ardu geflasht wurden.

      4. Wird beim erneuten Flash der Ardu kommplett überschrieben?

      was hast du gemach?

      Antworten
  8. Avatar
    Uwe sagte:

    Hallo zusammen.
    Habe den Bausatz nach besten Wissen verlötet und vermute, dass ich auch den Arduino geflasht habe (ohne MultiChannelDivice). Ich muss dazu sagen, dass dies mein erstes Arduinoprojekt ist und ich was das betrifft ich null Vorkenntnisse besitze. Von daher bitte ich schon mal um Nachsicht, auch wenn es für euch einfache Fragen sein sollten. Der Arduino blinkt anfänglich schomal zyklisch beim anschließen vom USB-Kabel an den Rechner. Was ich noch nicht verstanden habe, ist das Einbinden des „MultiChannelDivice“. Die anderen „Treiber“ hatte ich vorab eingebundenn (ZIP-Datei) und geflasht. Beim MultiChannelDiice komme ich per Link nur das Skript angezeigt.
    Frage:

    1. wie bekomme ich die Datei/Skript in den Ardu. rein?

    2. Wird die Drahtantenne nur in der Mitte der drei Lötösen auf dem Transceiver verlötet oder können/müssen alle Lötpunkte genutzt werden?

    3. Wie prüfe ich nach, ob alle „Treiber“ auf den Ardu geflasht wurden.

    4. Wird beim erneuten Flash der Ardu kommplett überschrieben?

    Vorab vielen Dank für eure Unterstützung!

    Uwe

    Antworten
    • Avatar
      Michi sagte:

      Hallo zusammen,

      da ich ein absoluter neuling bin habe ich das ganze zwar gelötet bekommen aber mit dem Flashen usw klappt es überhaupt nicht auch wenn es eine Ordentliche anleitung ist.

      Hoffe es kann mir jemand Helfen

      Antworten
      • Avatar
        Uwe sagte:

        Hi Michi.

        Habe auch gedacht das man die Platine/Bausatz sauber lötet und dann ein Sketch flasht und dann „nur“ noch in die Homatic einbinden und fertig. War leider nicht so. Habe mich dann aber erstmal mit einigen Grundlagen vertraut gemacht, was aber anscheinend (bei mir) nicht reicht um das Projet zu begreifen. Ich selbst habe dann (unbewusst) einen Sketch geflasht bei dem dann fast alles funktioniert außer die richtige Anbindung an die Homatic (CCU3). Ich hab es jetzt das Projekt erstmal auf stand by gesetzt. Manchmal ist das ja besser um einen anderen Blickwinkel zu bekommen. Ich möchte daher hier kein Halbwissen weitergeben. Nur soviel, dass die Hardware anscheinend funktioniert. Schreib mal wie es bei dir weitergeht. Gruß Uwe

        Antworten
        • Avatar
          Michi sagte:

          Werde das ganze jetzt erstmal auf Eis legen „leider“ da ich es nicht geflasht bekomme. Schade eigentlich da es ein echt schönes Projekt ist.

          Wo bist du noch Vertreten Uwe? Vielleicht hättest du mir Weiterhelfen können

          Antworten
    • Avatar
      Heiko sagte:

      Hallo Uwe !
      Auch ich bin Arduino Anfänger, bin aber einen Schritt weiter gekommen :-)
      1. Ich habe die Library „MultiChannelDevice“ nicht benötigt. Das kompilieren hat
      so funktioniert und bei mir tut das Ding auch seinen Dienst.
      2. Die Antenne nur an der mittleren Lötöse anlöten, die anderen beiden Kontakte sind GND, falls
      eine externe Antenne genutzt werden soll
      3. Wie gesagt – ich bin auch Anfänger. Du kannst im Menu „Sketch“/“Bibliothek einbinden“/“Beigetragen Bibliotheken“ sehen, welche Libraries eingebunden werden. So wie ich das ganze verstehe, sollte
      alles in Ordnung sein, wenn beim Kompilieren keine Fehlermeldungen auftreten (das ist aber nur
      eine Vermutung, ich hab zu wenig Erfahrung)
      4. Meines Wissens: Ja

      Antworten
  9. Avatar
    Wolfgang sagte:

    Der Zusammenbau und das Anlernen des 8-fach Sensors an eine pivccu3 hat funktioniert und die Temperaturwerte der 8 Sensoren werden in der pivccu3 (firmware 3.49.17) unter „Status und Bedienung“ angezeigt.

    Allerdings zeigt mir die pivccu3 unter „Einstellungen->Geräte“ den Sensor unter „Typenbezeichnung“ lediglich als „DEVICE“ an und unter „Bezeichnung“ steht „Unbekanntes Gerät“. Ein Bild des Sensors (Thermometer) wird nicht angezeigt. Der Temperatur-Offset der Sensoren lässt sich aber konfigurieren.

    Die Installation habe ich wie hier beschrieben durchgeführt: https://github.com/jp112sdl/HB-UNI-Sen-TEMP-DS18B20 inclusive dem aktuellen JP-HB-Devices-addon (v2.18).

    Wie kann ich tun damit das Gerät richtig erkannt wird und das Icon richtig angezeigt wird ?

    Antworten
    • Avatar
      Wolfgang sagte:

      Jetzt läuft es auch bei mir: Zurückspielen des letzten Backup in die pivccu3 und neu installieren des JP-HB-Devices-addon (v2.18) hat das Problem beseitigt.

      Antworten
  10. Avatar
    Roland sagte:

    Hallo Sebastian,

    die drei gekauften und zusammengebauten Platinen funktionieren hervorragend. Sie werden nun über Netzteile betrieben. Danke für die Arbeit.

    Bisher nutze ich den HM-WDS30-OT2-SM der mir neben den zwei Temperaturen auch deren Differnztemperatur liefert. Mit dieser kann ich dann elegant in einem Programm eine Steuerung vornehmen.
    Leider liefert der 8-fach Temperatursensor keine Differenztemperaturen. Um das nachzubilden müsste ich die Temperaturen in einem Skript auslesen und dann in einer Systemvariablen abspeichern.
    Eleganter für mich wäre es wenn ich das Skript im Arduino so erweitern könnte dass es zwei Differenztemperaturen ausgibt. Bei mir wären das dann 6 Temperaturen und 2 Differenztemperaturen.

    Kannst du mir da einen oder einige Hinweise geben, wo ich im HB-UNI-Sen-TEMP-DS18B20 eingreifen muss und was ich nicht verändern darf!!

    Antworten
  11. Avatar
    Robert sagte:

    Warum lernt sich dieses Ding nicht an meine Raspberrymatic an.
    Hab schon ein Paarmal den Frequenz test durchgeführt der auch erfolgreich beendet wird. Dann wie beschrieben wieder den Sketch drauf spielen. Leider findet die Raspberrymatic das Teil nicht. Hat noch jemand eine Idee?

    Antworten
    • Avatar
      Roland sagte:

      Der Sensor ist ein Homatic Produkt. Kann es sein dass du versucht hast es als Homatic IP anzulernen? Das würde den Fehler erklären.
      Einmal ging es bei mir auch nicht und ich hatte eine Löstellte vergessen.

      Antworten
      • Avatar
        Robert sagte:

        Das weiß ich das es nicht IP ist, Lötstellen alle OK, es will einfach nicht. Bin mal gespannt wie es hier mit Garantie aussieht.

        Antworten
  12. Avatar
    Dieter sagte:

    Hallo Sebastian,
    ich glaube da ist zwischenzeitlich ein Bug in der Anleitung. Ich komme doch irgendwann an den Punkt an dem ich das Muster-Sketch öffnen muss (ist das HB-UNI-Sen-Temp-DS18B20.ino ? Dein Link läuft ins Leere). Wenn das der richtige Sketch wäre scheiont der kaputt zu sein (gefunden habe ich ihn über Github: „jp112sdl“ und von dort zu „machtnix“ weil auch unter jp112 kein funktionierender Link oder ino-File war. Das File was ich dann von „machtnix“ dowloaden konnte enthält m.E. aber kein korrektes Sketch (das schaut eher wie ein Style-Sheet oder so aus; bin kein Programmprofi).
    Kannst Du bitte helfen, da ich sonst den Bausatz nicht in Betrieb nehmen kann. Keine Ahnung wie die Vorredner das geschafft haben. Wie oben erwähnt: Vielleicht ist die HB-UNI-Sen-Temp-DS18B20 inzwischen defekt?
    Danke, Dieter

    Antworten
  13. Avatar
    Dieter sagte:

    Sketch?
    Irgendwas stimmt noch nicht. In der Beschreibung steht „Sketch laden“ (als Link) der Link endet aber in „404-Fehler“. Laut Jerome müsste an diesem Punkt noch eine fertige Bsp-Datei geladen werden, da wird die Anleitung dann aber leider dünn.

    Antworten
      • Avatar
        Thomas sagte:

        Kann ich bestätigen, habe das Gerät vorgestern „programmiert“ und es hat alles soweit ganz gut geklappt wenn man sich an die Links aus den Kommentaren gehalten hat.

        Antworten
  14. Avatar
    Urban sagte:

    Hallo,
    Habe den Bausatz in Betrieb genommen alles funktioniert so weit problemlos, jedoch werden immer nur von 4 Sensoren die Temp.in HomeMatic angezeigt. Im Monitor vom Adruino werden 8 Sensoren gefunden und die Temp. angezeigt.
    Wo liegt der Fehler?

    Antworten
    • Avatar
      Roland sagte:

      Das Problem hatte ich auch mal. Ein Kabel war vertauscht und die Anschlussreihenfolge auf dem PCB hatte ich nicht eingehalten.

      Tipps: Schau dir die Lötstellen nochmals genau an. Evt. Nachlöten.
      Anschlussreihenfolge 1 bis 8 einhalten.
      Die Anschlussreihenfolge der Sensorkabel mit der PCB abstimmen.
      Vieleicht ist auch ein Sensor defekt -> Rundtausch der Sensoren

      Antworten
      • Avatar
        Urban sagte:

        Habe das alles ausprobiert, die Sensoren funktioniren mit einem Raspberry ohne Probleme.
        Im Monitor auf dem Adruino werden die Anzahl der Sensoren und die Temp. auch angezeigt.
        Kann nur eine Einstellung am Programm sein. Egal wo und wie viele Sensoren ich anklemme, es werden in der HomaMatic immer nur 4 angezeigt.

        Antworten
  15. Avatar
    Thomas sagte:

    Hi,
    du schreibst „Bei den Widerstanden müsst Ihr für R1 den 470 Ohm verwenden und für R2 den 4,7k Ohm“.
    Im Bild 10 ist der „Obere“ Widerstand laut Platine R1.
    Laut Codierung ist dort der 4,7k Ohm Widerstand verbaut.
    Um ganz sicher zu gehen… Wie herum ist es richtig? :)

    Antworten
  16. Avatar
    Roland sagte:

    Die Sensoren laufen nun seit 2 Monaten hervorragend. Leider brauche ich nun schon den 2ten Batteriesatz.
    Habe heute Ströme gemessen.
    – Ruhestrom 5,4mA
    – Sendebetrieb bis 25mA

    Dann bin ich auf den tollen Beitrag gestoßen in dem eine Lösung dargestellt wird.
    https://technikkram.net/2018/07/homematic-diy-sensor-batterielaufzeit-verlaengern-ldo-und-led-entfernen
    Die LED lötete ich wie angegeben aus und der Strom reduzierte sich
    . Ruhestrom 4,3mA
    Den Spannungsregler traute ich mich nicht auszulöten.
    Nun suche ich ein Netzteil mit dem ich die 6V und die 25mA bereitstellen kann.
    Kennt einer eine einfache Schaltung die ich kaufen kann?
    Alternativ kaufe ich mit einen Trafo, Gleichrichter, Kondensator und 6V Spannungsstabilisator und hoffe dass ich dann eine gute konstante Spannung bekomme.

    Antworten
    • Avatar
      Roland sagte:

      Ergänzung: Die 4 AA Batterien sind nach 2 Monaten wieder leer.
      Habe mir zwischenzeitlich ein kleines Netzteil gebaut.
      Trafo 0,5VA, Brückengleichrichter mit einer Kondensator Widerstandskette zur Spannungsglättung.
      Sebastian hat die Platine so ausgelegt dass sie mit dem 24V Fußbodenaktor zusammenarbeitet. Der braucht auch einen Trafo.

      Antworten
  17. Avatar
    Dieter sagte:

    Hallo Sebastian,
    Paket ist da, freu mich schon auf den Zusammenbau und den Test. Kannst Du noch was zur Einbaulage der LED sagen (und vielleicht in der obigen Anleitung ergänzen)? Alles andere scheint selbsterklärend und mit den Fotos machbar (nach etlichen Original HM Bausätzen)
    Und nicht zu vergessen: herzlichen Dank für die Aufbereitung und Zurverfügungstellung der Bausätze. DANKE

    Antworten
  18. Avatar
    Dieter sagte:

    Hallo Sebastian,
    spricht was dagegen die Module (Arduino, Funkmodul, Spannungsregler) auf den Pinleisten zu stecken statt zu löten? Könnte ja durchaus sein dass die Chinaware mal getauscht werden muss …
    Danke vielmals, Dieter

    Antworten
  19. Avatar
    Dom sagte:

    Hallo Sebastian,
    ich habe anhand deines Artikels eine Kontrolle der Wassertemperatur samt Visualisierung in Highcharts und in die Mediola Neo App vorgenommen. Großes Dankeschön!!!

    Kleiner Wermutstropfen und konstruktive Kritik… musste leider feststellen, dass einige Links im Beitrag ins leere laufen und somit eine Realisierung nur mit Verzögerungen und langer Suche möglich war. Super wäre es, wenn die Links aktuell blieben. Der Artikel ist ja nicht sooo alt.

    Link zu den aktuellen JP-HB-Devices-addon Releases: https://github.com/jp112sdl/JP-HB-Devices-addon/releases
    Link zum Sketch HB-UNI-Sen-TEMP-DS18B20: https://github.com/jp112sdl/HB-UNI-Sen-TEMP-DS18B20

    Auch sind mir nur durch Zufall folgende Beiträge aufgefallen:

    – Frequenzkalibrierung (https://technikkram.net/2019/05/asksinpp-diy-fehler-anlernen-nicht-moeglich-cc1101-frequenz-automatisch-anpassen)

    – Einbindung in die CCU3 (Teil des Beitrages „Homematic DIY-Projekt: Thermometer und Hydrometer – fertige Platine im Eigenbau“ https://technikkram.net/2018/05/homematic-diy-projekt-thermometer-und-hydrometer-fertige-platine-im-eigenbau)

    – Highcharts https://technikkram.net/2019/05/alternative-diagramme-mit-highcharts-loggen-von-datenpunkten-auch-hmip-und-variablen-teil-2

    Diese wären zur Komplettierung dieses Beitrages IMHO auch sehr nützlich gewesen. Vlt. helfen diese Hinweise anderen interessierten Lesern.

    Mich persönlich würde noch die Einbindung anderer nützlicher Sensoren für den Aquarium Betrieb interessieren. Zb. einen Ph Sensor. Ist soetwas möglich?

    Beste Grüße und weiter so!
    Dom

    Antworten
    • Avatar
      Dom sagte:

      Hallo in die Runde,

      wollte nochmal zu meiner Frage nachhaken…

      Können weitere nützliche Sensoren für den Aquarium Betrieb eingebunden werden? Zb. einen Co2 oder Ph Sensor.

      Beste Grüße

      Antworten
    • Avatar
      Dieter sagte:

      Hi Dom,
      könntest Du mal prüfen ob Dein Link zum Bsp-Sketch noch das enthält was Du runtergeladen hast. Ich bin Deinem Link gefolgt (Danke hierfür) aber der Sketch enthält meiner Ansicht nach keinen funktionsfähigen Code …
      Danke vielmals, Dieter

      Antworten
  20. Avatar
    Christian sagte:

    Hallo,

    Ich habe den Bausatz zusammengelötet.
    Wenn ich in der Anleitung auf Sketch laden klicke, dann bekomme ich Error 404.
    Sorry ist mein erstes Arduino -Projekt..

    Antworten
    • Avatar
      Roland sagte:

      Hallo Christian,
      mir ging es ähnlich. Zuerst lief gar nichts.
      Habe mich dann erstmal mit dem Andruino auseinandergesetzt und da die einfachen Programme getestet. Wenn das läuft geht die Komunikation mit dem Andruino.
      Die nächste Hürde war dann wie binde ich die Libraries ein. Hier ist Sebastians Anleitung genau zu folgen.
      Als es dann immer noch nicht lief begann ich die Sendefrequenz abzustimmen.
      Heute läuft es problemlos.
      Lies auch die verschiedenen Kommentare hier bei technikkram durch. Sie haben mir sehr geholfen. Kannst auch Kontakt mit einem jungen Informatiker oder Elektroniker aufnehmen. Fast alle kennen den Andruino und können dir weiterhelfen.

      Antworten
  21. Avatar
    Roland sagte:

    Zuordnung der WEB UI zu den Anschüssen auf der PCB.
    Messe gerade die Zurodnungstabelle aus. Dabei stelle ich fest dass diese bei mir nocht chronologisch sondern „chaotisch“ verläuft.
    Anschluss Chanal
    1 5
    2 6
    3 7
    4 8
    5 4
    6 1
    7 2
    8 3

    Es stellen sich da die Fragen:
    Bleibt die Zuordnung auch nach einem Restart/Stromausfall/neues hochladen des Skrips erhalten?
    Wie wird die Reihenfolge festgelegt? Gibt es im Senson eine Kennung? Wäre es mit wissen der Kennung dann möglich die Reihenfolge in Sequenz zu legen.
    Ist ein Skript vorhanden mit dem diese Kennung ausgelesen werden kann?

    Antworten
    • Avatar
      Roland sagte:

      Da ich drei Platinen verbaue und diese im Dauereinsatz zu Heizungssteuerung genutzt werden war mir die Zuordnung der Schraubpositionen zu den Kanälen wichtig.

      s g r s g r s g r
      6 7 8
      !—————————!
      ! Ch1 Ch2 Ch3 !
      !—————————!
      !—————————!
      ! Ch7 Ch8 Ch4 !
      !—————————!
      3 4 5
      r g s r g s r g s

      s g r s g r
      1 2
      !——————!
      ! Ch6 Ch5 !
      !——————!

      s schwarz
      g gelb
      r rot
      Zahl Zuordnungszahl auf der Platine
      chx Chanal in der WEBUI

      Habe den Sensor in 6 entfernt und es hat sich das Zuordnungsbild verschoben

      s g r s g r
      6 7 8
      !—————————!
      ! Ch1 Ch2 !
      !—————————!
      !—————————!
      ! Ch6 Ch7 Ch3 !
      !—————————!
      3 4 5
      r g s r g s r g s

      s g r s g r
      1 2
      !—————–!
      ! Ch5 Ch4 !
      !—————–!

      Nach aktivieren des Sensors ergab sich die erste Zuordnung wieder.

      Wie in einem anderen Beitrag behandelt sind die Batterien sehr schenll leer. Daher habe ich ein Netzteil selber gebaut.
      Es gibt da auch die Möglichkeit vorhandene Kleinnetzteile (el. Rasierer, Händy, etc.) zu nutzen.

      Antworten
  22. Avatar
    Roland sagte:

    Habe zwei meiner drei 8-fach Platinen zusammengebaut. Die Zweite verhält sich beim freqtest und beim Hochaden des Skripts unauffällig. Sprich es sind keine Unterschiede zum Ersten zu erkennen.

    Wenn ich versuche das Zweite anzulernen dann bricht die Komunikation des Ersten zusammen. Es kommen nur noch Nullen an.

    Darf nur ein 8-fach Board im Netzwerk betrieben werden?
    Müsste nicht jeder Sender eine eigene Kennung haben?

    Antworten
  23. Avatar
    Roland sagte:

    In der obigen Stückliste ist als Temperatursensor der „DS218B20“ Sensor geführt. Der Link zeigt auf eine andere Komponente. Bei Alibaba ist dafür der „DS18B20“ zu haben und für den ist auch eine Bibliothek da.
    Kann ich die Bibliothek für den DS18B20 nehmen?

    Antworten
    • Avatar
      Roland sagte:

      Ja, wenn der Arduino startet zeigt er bei mir mit 2 Sensoren die Meldung

      -> Found 2 DS18B20 Sensors

      auf. Die Sensoren werden dann auch ausgelesen und die Temperaturen mit einer Nachkommastelle gesendet.

      Antworten
  24. Avatar
    Roland sagte:

    Habe nun einige Hürden genommen.
    das Board ist bestückt. Die Frequenz ist abgestimmt.
    Drei der vier Bibliotheken sind eingebunden und werden kompiliert- gelinkt und hochgeladen
    (EnableInterrupt/ Low-Power/ OneWire) einzig die MultiChannelDevice
    konnte ich nicht finden. Ist sie bei der AskSinPP-master enthalten?

    Auch ohne die MultiChannelDevice lässt sich alles letztendlich hochladen. Nur bekomme ich es nun als Homatic nicht angelernt.

    Antworten
  25. Avatar
    Roland sagte:

    Die HW habe ich nun zusammengelötet. Nun folgt noch die Software. Leider ist die Beschreibung für mich als einen der erstmalig mit dem Arduino arbeitet nicht selbsterklärend.
    Denke es mir in der Reihenfolge:
    In dem AskSinPP-master.zip sind alle Quellen des Programmes für den Ardoino enthalten.
    Nun müssen die se noch compiliert und verlinkt werden.
    Dann auf den eProm gespeichert ist der Sensor einsatzbereit.

    Wenn dem so ist fehlen mir die Anweisungen wie ich compiliere und Linke und dann die Daten aufspiele.
    Gibt es da im Netz Anweisungen?

    Antworten
  26. Avatar
    Roland sagte:

    Auf dem ersten und zweiten Foto ist der Arduino eingelötet, und neben Pin A4 und A5 auch A6 und A7. Es ist eine Stiftleiste mit 6 Stiften die winkelig 90° sind beigefürt. Muss ich hier jeweils 2 Stifte abbrechen und diese dann gerade biegen?

    Hat die PCB 2 Layer? Bei zwei kann ich die Leitungen einfach nachvollziehen.

    Antworten
  27. Avatar
    Andreas sagte:

    Die Sendoren sind auch auf der Datenleitung alle parallel verbunden!? könnte man auch mehr wie 8 Sensoren an einer Platine/Arduino betreiben? Wie müsste den Sketch anpassen?

    Antworten
    • Avatar
      Andreas sagte:

      Bitte bitte um einen Tipp. Für eine weitere Platine habe ich am Zieleinsatzort (Heizkreisverteiler) leider keinen Platz!

      Antworten
        • Avatar
          Andreas sagte:

          bezieht sich das auf die physikalischen Anschlussmöglichkeiten oder die SW-technische Begrenzung des 1-wire-Systems?

          Antworten
          • Avatar
            Andreas sagte:

            Lieber Sebastian, wenn denn der (in der Grundkonstellation) limitierende Faktor die SW ist, dann wäre es ganz net, wenn Du Tipps geben könntest wie die Grenze zu überwinden wäre …

          • Sebastian
            Sebastian sagte:

            Hallo Andreas, das ist leider nicht vorgesehen, da es hier verschiedene Faktoren wie z.B. die Homematic Zentrale, die Anzahl der Datenpunkte vom Arduino usw. gibt. Daher lässt es nicht nicht erweitern. Es werden maximal 8 Sensoren unterstützt.

          • Avatar
            Andreas sagte:

            Danke für die Erläuterung. Jetzt ist es mir klar und ich kann akzeptieren, dass sich eine weitere Forschung nicht lohnt. Da werde ich wohl mit 8 Messstellen auskommen müssen … Hab schon schwierige „Lebens“einschränkungen überstanden ;-))

  28. Avatar
    Münnich sagte:

    letztlich läuft die Konstellation auf 5V!
    Was spräche dagegen den Festspannungswandler raus zu lassen und direkt mit einem Handy-Ladesteckernetzteil 5V/1A drauf zu gehen?

    Antworten
    • Avatar
      Thomas sagte:

      Ach, da steht ja welche Sensoren, aber der Link zu Ali ist glaube ich falsch.
      Dennoch würde mich interessieren wie lang die Kabel der Sensoren sind (also die, die im Komplettpaket von euch enthalten sind). Danke!

      Antworten
      • Avatar
        Andreas sagte:

        da liest man unterschiedliches. ist letztlich abhängig von den umgebungsbedingungen. kabelqualität, schirmung, elektromagnetische störeinwirungen u.s.w.
        ich selbst habe bisslang nur max 3 meter mit einfachen 3-adrig ungeschirmten kabeln realisiert. habe aber auch schon von mehr als 10 meter gelesen.

        Antworten
  29. Avatar
    Markus sagte:

    Hallo,
    Du schreibst, die Platine braucht 24V. Auf der Platine und anhand der Bauteile meine ich aber 6 – 24V zu erkennen?! Ich möchte mit meiner 12V Solaranlage (11.0 – 14.8V) das System betreiben. Geht oder geht nicht? Und wenn nicht, hast Du einen Änderungsvorschlag?

    Antworten
    • Sebastian
      Sebastian sagte:

      Nein, die Sensoren gibt es bis ca 120C. Bei solchen Anwendungen benötigst du ein PT100 oder ein Thermoelement welches diese Temperaturen aushält. Das wäre dann aber auch eine andere Schaltung.

      Antworten

Hinterlasse ein Kommentar

An der Diskussion beteiligen?
Hinterlasse uns deinen Kommentar!

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.